Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2022 - 01:00 UTC
Scheduled
We will be performing routine maintenance on the user portal, this will cause a short period of downtime. You can still access bare metal services at https://metal.portal.kuxo.io
Posted May 03, 2022 - 20:27 UTC
This scheduled maintenance affected: Billing System.